0
$\begingroup$

I'm trying to render an image that has a wall of windows through which sun should be reflecting into an environment, and a pool with a glass wall facing that wall of windows. At the moment I'm going for having the light be sort of natural. The camera is positioned so it seeing part of the outdoors through the water, the glass wall of the pool, and the glass of the windows.

I set up the water, glass in the windows, and the glass of the pool wall as the same material - it uses a set of nodes to allow transparency and accurate reflections without getting into caustics, it's in the wiki manual and also documented in an answer here.

nodes for 'tricky glass' and camera view

However, nothing can be seen through the windows, and lights I specifically put in to shine through the glass of the pool aren't visible, except for one, a little. Those I put in just to see if they would show.

enter image description here

I have tried increasing the Render Light Paths settings so that Transparency, Bounces, and Transmission are all at 50. I've tried increasing the Camera Clipping End Distance to 2000. I moved the objects in question to a new file so that things that were set up as linked groups are instead local, to check materials. Nothing has changed.

What is the issue here?

Edit: I have tried two alternate approaches to a glass material that seemed like they might help, with no luck.

The first is shown by Dorian Zgraggen here:

enter image description here

The second is shown by Michael Ting here:

enter image description here

I remain completely confused as to what the problem is. For now, I simply replaced the window glass with an invisible material (by switching the shadow ray for a camera ray in the material in the first screenshot above). I am going to try putting a lot more light under the pool, and then I'm completely out of ideas.

$\endgroup$
2
$\begingroup$

The issue was that the 'Simplify' checkbox was checked, under Properties > Scene, at the bottom.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.