1
$\begingroup$

If I have two objects or more overlapping, RMB will select whichever is furthest away in the overlap. This seems counterintuitive. Is this how selection operates by default or is this a setting I've turned on/bug??

$\endgroup$
4
  • $\begingroup$ This shouldn't happen. Could you share a screenshot of this happening and also the blend file if possible.You can use blend-exchange.giantcowfilms.com for sharing the blend file $\endgroup$
    – Teja
    Sep 2, 2018 at 20:52
  • $\begingroup$ The file I uploaded is an example where I've loaded factory reset settings, created two cubes and when I click the RMB on the foreground cube it selects the background. With more complicated files it selects whatever is furthest away and it's like this with every scene I create. Here's the link to the .blend file: <img src="https://blend-exchange.giantcowfilms.com/embedImage.png?bid=5187" /> and the screenshot: ibb.co/jXj5Ee $\endgroup$
    – John
    Sep 3, 2018 at 2:26
  • $\begingroup$ With multiple items under the mouse, the first click should select the one in front (if it is not already selected), subsequent clicks will cycle through selecting each object. Check that by selecting another object before clicking the overlapping objects. In preferences under system, you will find two selection settings, try enabling depth picking and/or different selection methods. $\endgroup$
    – sambler
    Sep 3, 2018 at 3:15
  • $\begingroup$ That sounds right as to what should be happening. For some reason it's selecting the background object first. Tried all of the selection preferences under system to no avail. $\endgroup$
    – John
    Sep 3, 2018 at 4:04

1 Answer 1

1
$\begingroup$

For anyone encountering this problem in 2.8x+, enabling Depth Picking in Preference > Viewport > Selection solves the problem

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .