0
$\begingroup$

I have a problem with the lamps. When I first create them, it all goes fine. But at some point of making them, or when I deselect them and work in other stuff, they get lost in the viewport. Only their light is visible in the material mode, and they still appear listed in the outliner, but I can't select them.

If I try to create new ones, they don't cast any light.

What can I do? Is there any way to reset the lights or something?

Thank you so much!

P.S. I'm using the Blender Render engine.

EDIT: I was asked to post some screenshots, so I tried to put lamps on my project again.

ss 1

This time, the lights didn't work from the very beginning. I haven't changed anything in the project since the last time I tried, so this behavior in Blender seems completely senseless to me, like a bug.

ss 2.

Here, I turned off Environment Lighting.

ss 3.

These are the material settings for the mesh I'm trying to put the lights in.

$\endgroup$
  • $\begingroup$ Could you post the a .blend file or some screenshots? $\endgroup$ – Ben Sep 2 '18 at 1:07
  • $\begingroup$ @Ben yeah, done! $\endgroup$ – Sebastien Yokubo Sep 2 '18 at 2:28
  • $\begingroup$ For those with the same problem, I already found the solution: I was in the local view, and I got out pressing "/". Idek when did I enable it, lol $\endgroup$ – Sebastien Yokubo Sep 3 '18 at 3:56

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.