I have been using blender for a few years and this is the first time I have come across this problem. I am running 2.79 on Ubuntu. I was trying render a short test video for a new project and I came across this error on the top of my blender feed.

"Could not open file for writing"

And occasionally I get the error "Python: RENDER_MT_presets"

There is a triangle caution sign on the left of it. I am trying to write to the same folder of my last 6 videos. I found several videos just saying that I need to change the output source, but that didn't work. I also found this post on the forum. Deleted .dvd file, and "Could not open file for writing." I tried changing the permission for the folder, but again it had no effect. I am now confused by this and am hoping that someone could help.

enter image description here

  • $\begingroup$ The "Could not open file" error sometimes appears when you delete /move the rendered file and then try to render with that same name to that same location again. Try to change name of the output file. $\endgroup$ – Mr Zak Aug 31 '18 at 18:45
  • $\begingroup$ Check in compositing or materials if any input nodes require a local texture file. $\endgroup$ – John Sep 1 '18 at 2:01
  • $\begingroup$ I wonder if the space in your folder name is the cause. If you open a terminal window and start blender from there, you should get some extra error info that may help figure out what the problem is. The RENDER_MT_presets error is referring to the preset menu above the render resolution, this would save to $HOME/.config/blender/2.79/scripts/presets/render/. $\endgroup$ – sambler Sep 1 '18 at 5:37
  • $\begingroup$ Hi John, Thanks for the reply. I'm not sure how to check that. I have never had to go into the deeper settings. I'm just curious as to why this was working 2 weeks ago, but now this is giving me this issue? $\endgroup$ – Colmeweb Sep 1 '18 at 17:17
  • 1
    $\begingroup$ You might have relative paths in your input nodes and might moved your blend file or the source images. To check go to the compositing view from scene. To debug precisely, maybe use the toggle system console from window and post the error $\endgroup$ – John Sep 1 '18 at 17:27

In properties window, go to "Output" tab. Find "Output" heading within that tab. Check the "File Extensions" box (which is below the Output save path entry).


Just had the same problem, solved by re-linking the render folder location through the Output tab in the Properties Window, clicked on the folder tab and chose the same folder. Rendered correctly afterwards.


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.