1
$\begingroup$

Firstly I understand that blender 2.8 is a release candidate, that being said...

I modeled and rigged my character in 2.79, opened it in 2.8. it seems odd to me that the rig isn't visible. I can see the IK endpoints (hands/feet), but none of the FKs, armatures, or tweaks.

it kind of seems like the layers are invisible (2.8 doesn't use layers anymore?), just curious if this is something im doing wrong or if it's a 2.8 bug. no rig

$\endgroup$
  • 2
    $\begingroup$ No, blender is not release candidate yet, it is in alpha state. It's mean that addons like rigify are disabled, and will not update until python api will be freeze in beta release $\endgroup$ – Crantisz Aug 31 '18 at 6:55
  • 5
    $\begingroup$ I'm voting to close this question as off-topic because it is about unfinished experimental development software. $\endgroup$ – Duarte Farrajota Ramos Aug 31 '18 at 8:25
  • $\begingroup$ "off-topic" seems like a terrible scapegoat; however, I'll gladly accept an answer stating "because blender 2.8 is under development addons (in-general) are disabled for that release" as @Crantisz suggests. i just found it odd because invisible bones seems like a layer(?) issue, not a python issue :/ also, are we able to close our own questions? $\endgroup$ – kei Sep 1 '18 at 0:12
  • $\begingroup$ I answered this with an easier solution in this post: blender.stackexchange.com/questions/133984/… $\endgroup$ – RocketFriday Mar 15 at 4:20
5
$\begingroup$

I have found the problem to this, u have to go on pose mode find the bone (ctrl) in the properties under display and for some reason the wireframe is off. You have to enable it for every ctrl bone.enter image description here

Cheers!

$\endgroup$
3
$\begingroup$

If going into edit mode and back after selecting all doesn't work the just enable your 'WGT' collection

Number 1 Check where your 'WGT' collection is then select the screen button to enable the collection

Number 2 Then make sure the collection is visible.

Then all you do is select all, go into edit mode and back into object mode and your rig should be visible now, just hide and disable the 'WGT' collection again

$\endgroup$
1
$\begingroup$

Your rig can be visible by showing all "WGTS_rig" meshes, select all, then go to edit mode and back to object mode. Your rig will be visible.

$\endgroup$
1
$\begingroup$

Simply select all, go into edit mode (you will see the rigify stuff) then go back to object mode and bam. I can see my Rigify Rig.

$\endgroup$
0
$\begingroup$

Sorry for being too lazy to google further, but as I read from somewhere then, the solution/problem is that the riggify geometry is too thin. When the lines are made thicker, then it will be more visible.

$\endgroup$
  • $\begingroup$ There is not need to start out with "Sorry for being too lazy to google further..." just put the answer you know. You can always come back later and edit it after you googled further and got more detail on the answer. $\endgroup$ – David Nov 3 '18 at 0:53
0
$\begingroup$
  1. Select all bones press 'A' then turn on the Wireframe in the Display shape bone mode and then right click it and select 'copy to selected' then go out of the pose mode and you should see all your controllers.
  2. To bring back layer Tab where you select the visibility of each layer, go to text editor in blender and pick a '..._ui.py' script that should be in your file in my case its 'girl_ui.py' then press run script and check internal so it runs every time you open a file.

If you still dont see the layer tab then you need to check the id of the rig which you can find in 'object data' tab under Custom properties id='895892594325sdj' you have to copy it into the script you try to run for your character UI pannel. It should be at the beginning id='something' replace it with a new id and RUN it again!

I hope it helps!

$\endgroup$
0
$\begingroup$

2.8 is now in Release Candidate! I bet most newbies who can't see their armatures aren't in edit mode.

Also, you need to select one and go into Context pane / Object options and check In Front to make your armature appear filled and "in front" of wireframes.

enter image description here

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.