0
$\begingroup$

I'm relatively new in 3D Scanning world: I've scanned the model using XYZ 3D scanner saved as .OBJ file with *.mtl and .png texture file. No errors, nothing it just does not import the model. I have no problems opening it with Meshlab but Blender fails to import it. I've tried to convert it to fbx or ply with Meshlab - no success opening it with Blender. Tried use previous version of Blender - the same issue. Is there any compatibility problem between Blender and models scanned by XYZ 3D Scanner ? For example when I made the model using Autodesk 360 Recap from the pictures Blender has no problems opening it. Id there any workaround this ? Why Meshlab can open the model but Blender can not ? Really like Blender but unfortunately can not use it to edit 3D models scanned by XYZ Scanner.

Thank you,

Alex

$\endgroup$
  • 1
    $\begingroup$ Looks like it's an issue related to that specific file. Bender shoud be capable of open .obj files. Without a sample file the suffers from this, it's hard to make a diagnosis. Could you share a small sample file? $\endgroup$ – Carlo Aug 30 '18 at 21:56
  • $\begingroup$ Carlo, I've done another simple scan not able to open obj with Blender. The zipped file size is 5M with obj, mtl and texture file. I've downloaded it to filedropper.com/sample_23 $\endgroup$ – Alex V. Aug 31 '18 at 19:38
  • $\begingroup$ Carlo, Just figured out: it actually IMPORTS the obj file. However the model is really really far away from the center of coordinates, I have to zoom in really deep to be able to see. Also I do not see the color. Is there any simple way to move to 0,0,0 and then be able to see the colored model like I can see it in Meshlab ? $\endgroup$ – Alex V. Aug 31 '18 at 19:55
1
$\begingroup$

Import is correct: change origin and shading mode

Once you correctly export the file to OBJ format, there should be no issue related to the source.

Blender is correctly importing the geometry in the scene while keeping the object's original coordinates (Meshlab doesn't). You con manually reposition your object or run the "Set Origin" operator (choose Origin to Geometry option) and then the "Clear Location" operator to move the object to the center of the scene.

Blender is also loading the texture, but they are not shown in Solid mode. You'll have to switch to Texture mode, or Render, or even Material mode (after simplifying the nodetree in this case). You can find a detailed explanation of the Shading mode for the 3D viewport in the Manual's page

enter image description here

.

$\endgroup$
  • $\begingroup$ Thank you for your help, I can view move the object to the center now but still not able to view the colors even using different options above like Material or Solid: I have found number of posts where people are complaining about not been able to view the color from the texture files for obj files: tried to provide the full path to material file and the texture file - does not work. I see by default Blender wants to have it the material and texture files in the same directory where obj file without the pass. Meshlab has no issues showing the colors for obj made by XYZ scanner. $\endgroup$ – Alex V. Sep 5 '18 at 0:26
  • $\begingroup$ I had no issue in seeing the texture in Texture mode for the file you uploaded: i.stack.imgur.com/Xlzgd.png. Do your problems concert that file or another? $\endgroup$ – Carlo Sep 6 '18 at 20:39
  • 1
    $\begingroup$ Carlo, this has been resolved, Thank you for all your help, after I did Solid and rendered the the texture I was able to see my color. $\endgroup$ – Alex V. Sep 8 '18 at 20:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.