I have Blender installed on a Linux machine with 6 Nvidia GPUs (GTX 1060)

I have an ssh connection into it but it doesn’t look like Blender is using the GPUs. The command I am using is as follows:

Sudo blender -b RenderTest.blend -a -o <location>

It's taking around 2 minutes to render a frame, on my Windows PC it took 1 minute with a single 1080TI, using the top command it shows my CPU at 200% indicating it's currently using 2 CPU threads.

How can I fix this so it uses all 6 GPUs?

  • $\begingroup$ Hello and welcome to Blender.SE. Have you tried launching Blender together with a script for setting up the GPU calculation, as suggested here? $\endgroup$
    – Nicola Sap
    Aug 28 '18 at 16:34
  • $\begingroup$ @NicolaSap I tried that script, however nvidia-smi shows that the gpus are not running any processes $\endgroup$ Aug 28 '18 at 16:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.