0
$\begingroup$

I made some characters in blender, and armature deform with automatic weights. everything goes fine, except the arms. Import them in unity3d as humanoid, and play an idle animation, the arms should be straight, but all of the arms are rotated backwardly.

I spent hours, tried to paint different weights, moved bones. But problems remain.

Thanks for any insight.

https://www.dropbox.com/s/yl3div22tf8gkuv/seaman.blend?dl=0

enter image description here

enter image description here

$\endgroup$
  • 1
    $\begingroup$ could you please share one of your object+armature? blend-exchange.giantcowfilms.com $\endgroup$ – moonboots Aug 26 '18 at 12:08
  • $\begingroup$ Yes, blender file. dropbox.com/s/yl3div22tf8gkuv/seaman.blend?dl=0 $\endgroup$ – Jackie Aug 27 '18 at 9:02
  • $\begingroup$ what do you mean when you say that the arms rotate backwardly? they look fine, except that the weight painting needs adjustments + you need IK + deactivate the Manipulate Center Point button on the horizontal menu bar $\endgroup$ – moonboots Aug 27 '18 at 9:11
0
$\begingroup$

It's possible that mechanim's humanoid system prefers the bones to have a particular orientation to them, and it's automatically trying to fit your bones to that orientation, which causes the arms to rotate backwards. In blender, go to edit mode of the armature and enable Object Data > Display > Axis. This allows you to see the current roll of each of your bones. Then in the properties panel > Transform with a bone selected, you can change the roll of that bone. If the arms are rotating 180 degrees in unity, then I would suggest rolling each of the arm bones by 180 degrees to see if this fixes the problem.

Also, it is helpful for ik solvers (like what mechanim uses) if the resting pose of the appendages are slightly bent indicating which way the appendage should bend toward. For example, you could change the t-pose of your character to have slightly bent elbows which would indicate to the solver the the arms should bend in that particular way, and this could help Unity set up the orientations correctly. enter image description here

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.