1
$\begingroup$

The following works with Open Shading Language unchecked in the Render panel

OSL off

but as soon as I check the Open Shading Language box, the material goes completely black. Adding an OSL script node in the same file work correctly so I have OSL set up correctly.

The problem appears to be with the Normal node, as feeding the Normal output of the Geometry node directly into the Emission node works whether OSL is on or off.

Blender 2.79

$\endgroup$
  • $\begingroup$ I get this, too, across to a 2018-08-06 build of 2.79.. $\endgroup$ – Robin Betts Aug 24 '18 at 5:57
  • $\begingroup$ So, what is your question? $\endgroup$ – Duarte Farrajota Ramos Aug 24 '18 at 11:10
  • $\begingroup$ I’ve also replicated this - looks like a bug to me. Enabling/disabling OSL shouldn’t affect this node. Only option to work around would be to replicate the functionality another way - eg, Mapping node for the Normal output (rotating the normal) and Vector Math ‘Dot Product’ for the ‘Dot’ output (dot product of a vector and the incoming normal). $\endgroup$ – Rich Sedman Aug 24 '18 at 12:18
  • $\begingroup$ Thanks for confirming the bug, I've filed a bug report. developer.blender.org/T56623 $\endgroup$ – elfnor Aug 30 '18 at 22:36

Browse other questions tagged or ask your own question.