Have an issue with importing/exporting animation into Blender using Collada.

Steps taken:

  • Export character from Mixamo with simple walk cycle in .dae format
  • Import file into Blender.

The result is the mesh getting distorted.

Stuff I've done:

  • Quaternion rotation
  • Changed to blender render (apparently, cycles was giving an issue)
  • Clear scale, rotation, normals, etc
  • Zero coordinates
  • Not use better collada (didn't work trying to use it)
  • Baking animations using recommended settings
  • Default settings from export and every other setting
  • Exporting the animation/skeleton purely as .dae
  • Pretty much whatever I could find online, blender stack exchange forums/etc
  • 1
    $\begingroup$ Nvm, turns out it's a collada bug. Sent a bug report to the devs. developer.blender.org/T56516 $\endgroup$ – cereszal Aug 27 '18 at 8:59
  • $\begingroup$ I'm having the exact same bug with the same set of meshes that you were using. I saw in the bug that theoretically it was already fixed, but it seems that the bug is still happening using latest blender release. Was the bug ever fixed? $\endgroup$ – felipeek Dec 23 '19 at 21:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.