0
$\begingroup$

I know I'm probably making some silly mistake after hours of consecutive work.

I have a cylinder representing a gun barrel, and at one point I want to add a 'ring' around the barrel, as shown below.

At the point shown, I added an edge loop, beveled it with hopes of extruding it along the normals, however I'm getting weird behavior.

The faces refuse to extrude outward, and will only go sideways like the second image. Here's my interface too, which I scanned for mismatched settings but can find none.

Can you see what's wrong? I checked for duplicate geometry, found 0 double vertices and I tried doing it with a new primitive cylinder, and it works like a wonder. Thank you!

$\endgroup$
0
$\begingroup$

Hard to say where you've messed up, anyway, here is what you should do, if I've correctly understood what you try to do (?):

  • Create your edge loop at the middle of your cylinder with ctrl R.
  • Bevel it with ctrl B.
  • Press E to extrude then Enter right away.
  • Press S to scale your extrude, and shift X (or Y depending on the orientation) to constraint your extrude on both Y and Z axis.

enter image description here

$\endgroup$
  • $\begingroup$ Thank you, this worked. I was so absorbed with the vertex normals that I didn't even try the simple solution. $\endgroup$ – Dimitrios Kokkaliaroglou Aug 23 '18 at 10:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.