2
$\begingroup$

I have misplaced objects camera and lights. They do not show in the 3d viewport yet the object shows up in the rendered window. I thought perhaps I had accidentally moved the entire lot away from the grid, however the location of the object still shows to be x0 y0 z0. They are also not hidden or in another layer. They do show in Outliner and the rendered preview window. There is a strange gray line. What have I done?enter image description here

$\endgroup$
  • 2
    $\begingroup$ I took a look at your blend. I think its a bug, if you switch from the default mode to any of the other ones it appears just fine. Its something that got messed up with the default view. I tried it with 2.8 and it worked just fine. My only advice is start up a brand new .blend file and append > import > objects. Then everything will be back to normal. Not sure what happened to your default space. $\endgroup$ – icYou520 Aug 21 '18 at 20:51
  • $\begingroup$ LS1, have you switch from a version to another? $\endgroup$ – moonboots Aug 21 '18 at 20:59
  • $\begingroup$ @moonboots No I have not. I was working on it just fine and then all of a sudden everything went. I assumed I had typed in some weird shortcut key by mistake. $\endgroup$ – LS1 Aug 21 '18 at 21:16
  • $\begingroup$ yes it's weird, but as icYou says, you can get your objects back $\endgroup$ – moonboots Aug 21 '18 at 21:17
  • $\begingroup$ @icYou520 I have done just what you have suggested and appended all into new blend file. All working fine so at least I can get on with the work! $\endgroup$ – LS1 Aug 21 '18 at 21:26
5
$\begingroup$

You have set a view clipping border. This allows you to only see a portion of the scene for clarity, as this cuts through objects it is also good for seeing inside an object.

The small dark area you have is the visible area in the viewport, as none of your objects are in there, you don't see anything.

You set the clipping border with ⎇ AltB and drag a rectangle over the area you want to see. Pressing ⎇ AltB again will clear it.

Also if you turn off the Load UI option when opening the blend file, the existing border will not be loaded.

$\endgroup$
  • $\begingroup$ Thank you @sambler. Not sure how i could have done that without knowing, but after pressing the Alt and then B keys it did indeed make my object visible again. $\endgroup$ – LS1 Aug 22 '18 at 14:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.