0
$\begingroup$

I have a simple table without any thickness, I started with a cube and deleted 3 of the faces, applied a subdivision surface modifier and did a few loop cuts to achieve this shape shown here: table no thickness

however when I try to add a solidify modifier to it, the thickness is not evenly distributed so the sides are thicker than the middle and the mesh also gets distorted shown here: table with thickness

I want the table to have a uniform thickness just like in real life, and get rid of the weird distortion, I am relatively new to blender and this might seem obvious but any help will be appreciated, thanks.

$\endgroup$
  • 2
    $\begingroup$ maybe try to apply the scale of your object: in Edit mode, ctrl A > Scale, because you may have made scale in Object mode instead of Edit mode. There also might be a topology problem as your object looks weird (artifacts). Also, click on the Even Thickness option of the modifier. $\endgroup$ – moonboots Aug 21 '18 at 12:57
2
$\begingroup$

You must have scaled your object in Object mode rather than Edit mode. If you do it in Object mode, Blender still considers the original size of the object when you'll assign it a Solidify modifier.

So you need to select your object and ctrl A > Apply Scale, so that now the scale you've made is applied to the mesh itself and not only to the object.

Also, enable the Even Thickness of the modifier, it could prevent some other distorsions.

And at last, your object mesh must be a little bit messy because you have strange artifacts, try to make a clean topology.

enter image description here

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.