0
$\begingroup$

Here's a simple shape with two bevel modifiers and smooth shading turned on, but the shading on the flat surface is distorted and wrong. I've tried recalculating normals with CTRL N. How can I fix this problem?

screenshot of the setup

$\endgroup$
  • $\begingroup$ Smooth shading doesn't work well with flat geometry (like yours). If you you want to smoothen your model, I would suggest applying SubSurf modifier and adding some loop cuts to your model. $\endgroup$ – AshKB Aug 21 '18 at 0:41
  • $\begingroup$ Smooth shading, without further instruction, interpolates the normal at any point in a face from the normals at its corners, so your picture showing normals illustrates why the face looks curved. There are so many approaches to controlling smoothing that your question is actually quite hard to answer.. which you choose depends on other things. You could just answer "Turn on Autosmooth in the Object Data tab", but it would be wrong a lot of the time. Start here, and ask again, if any particular way gives trouble. $\endgroup$ – Robin Betts Aug 21 '18 at 17:43
1
$\begingroup$

I found a solution to this particular problem of mine. After applying the bevel modifiers i inset the faces which where previously giving me issues. This made it near impossible to see when rendered but probably not perfect.

enter image description here

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.