1
$\begingroup$

Since a few weeks I suffer from the issue where I have to wait up to 6 sec after selecting an object in the viewport. The time depends on the amount of hidden layers (and hence the amount of objects visible). But the amount of objects visible from the moment this starts to happen are nowhere near stretching my system.

This question has been asked before, and I've been crawling through a number of bug-reports talking about this issue (or not) and they all seem to suggest that this should be fixed in later version. I'm working with Blender 2.79b and these bug-reports all seem to have this issue resolved for earlier version. So these fixes don't seem to apply for the current version anymore (or the features causing this are renamed, so I'm not recognizing them in the settings).

Also, the issue I'm having is often related to newe NVIDIA gpu's. I was using CUDA before (same computer, other arch-based installation) which seemed to perform way worse than my cpu when rendering, so I didn't jump through the hoops again to get it working. If I understand correctly CUDA has only an effect while rendering, it shouldn't affect performance while working in object mode, but maybe something I did driver-wise might have had an effect.

I've been struggling with this issue for a couple of weeks now, I hope someone can "render some lightrays onto my scene" ;-)

My laptop is a ASUS 4-core, some 2.5 Ghz, 16 Gb RAM with a Intel/Nvidia (bumblebee) GPU

$\endgroup$
2
$\begingroup$

Slow selection is usually fixed by changing the Selection mode in the System panel of the user preferences.

enter image description here

From the manual page about troubleshooting slow selection:

OpenGL Occlusion Queries (User Preferences)

See User Preferences ‣ System ‣ Selection.

This option defaults Automatic, try setting this to OpenGL Occlusion Queries, since there is a significant performance difference under some configurations.

$\endgroup$
  • $\begingroup$ Thanks, I think that solved it. I did change this setting earlier, although I forgot and noticed that blender was suddenly working fast again. So thanks to your answer I now also know what solved it ! $\endgroup$ – oneindelijk Aug 24 '18 at 22:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.