Well, I'm trying to render a simple chest, that's all, but it has some high definition textures and the vertex count is very high with SubSurf. I can work fine in the 3Dview, the thing is whenever I try to render my humble chest Blender flips the heck out and starts doing some very time consuming calculations, then RAM use go waaaay up and my whole pc freezes and never comes back A La Chavo del Ocho so I have to turn my PC off and on again. Then I thought, well I just have bake the textures that are causing this and the render will go fine. Well, I was wrong yet again and my PC freezes again, and the weirdest thing, when I use 1000 samples in the bake blender crashes after some time and my computer comes back, but when I use 200 it never comes back. My computer is very bad: Intel Core i3 3110M 2.40GHz 8gb DDR3 memory(dual 4096 MBytes) Intel HD Graphics 4000 Windows 10 Pro 64bits Laptop

I was under the impression that the only thing that was gonna happen were very long renders and that would be fine but now i'm afraid and sad that I need a new computer to go on with my studies and right now I cant. What can I do? Do I have to just do simple works while I wait to buy new hardware?

  • $\begingroup$ I would say you need to accept the reality that rendering computer graphics needs a lot of processing power and move on. You do need to buy a powerful computer if you wish to avoid issues like that, however you can learn to work with what you have as well. Try working on smaller parts of your project at a time, test rendering materials with simple lighting and render border only, research how you can optimize rendering in Blender. You can also use a render farm like SheepIt. Its free, you just need to render stuff for other people let's say during nights when you don't use the PC. $\endgroup$ – Martynas Žiemys Aug 18 '18 at 22:23
  • $\begingroup$ The most likely reason for such a crash is running out of memory - and for what you describe as a simple scene you should not be running out of memory. Please clarify more about your situation - such as how high definition the textures are (can you reduce them in size to see if that helps), how many vertices on your base mesh (can you do anything simple to reduce the complexity of your model), what level of subdivision are you using (does reducing that help?), are there any other modifiers in use? Try cutting it down until it works and then start adding complexity until you find the cause. $\endgroup$ – Rich Sedman Aug 18 '18 at 23:01
  • $\begingroup$ Well, I'm still in the first state of grief, Martin :c, but yes, I agree. I just don't feel confortable using render farms like sheep it since my computer can't even handle my things, so it would be like taking advantage. Aaaaa, thank you for the idea, @Rich, I will try it right now. $\endgroup$ – Graudhir Aug 18 '18 at 23:06
  • $\begingroup$ So @RichSedman, I had 4k textures and my uvs were set to 4096 x4096 so I halved that and put 2048 as the limit for texture in simplify but I guess just tweaking simplify was enough. But the last thing was the level of SubSurf that was in 5 and now has to be in 4. But, man, thank you very much, I had tweeked things but I did'n even thought in reducing the textures and tone down to the bare and go up slowly, it worked like a charm, thank you. Can you make an answer for me to choose, Rich? Since you did resolved this problem of mine. $\endgroup$ – Graudhir Aug 19 '18 at 9:39
  • $\begingroup$ Excellent - glad you’ve resolved it. I’ve added an answer. $\endgroup$ – Rich Sedman Aug 19 '18 at 10:34

The most likely reason for such a crash is running out of memory - and for what you describe as a simple scene you should not be running out of memory.

In order to reduce the memory requirement for your scene you could try reducing the size of your textures, simplify your mesh, reduce the level of subdivision surface modifiers (there are separate settings for Preview and Render - check both) and check for other modifiers that generate geometry (for example, a Remesh modifier can easily become a problem if set too high).

Simplify the scene and objects until you get a working render and then start adding complexity again until you find the cause.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.