1
$\begingroup$

I'm new to blender and trying to rig a model for animation later. I have made the model, and attached bones to the mesh. However, for some reason, the bones that control the right side of the mesh (right arm and legs) don't do anything, but the left side bones work but what they do is mirrored. enter image description here

enter image description here

$\endgroup$
  • 1
    $\begingroup$ could you share your file? for example on blend-exchange.giantcowfilms.com $\endgroup$ – moonboots Aug 18 '18 at 15:32
  • $\begingroup$ Did you applied Rot & Scale (CTRL+A+Apply Rot & Scale, in object mode) on your model before any skinning or rigging process? That could be the reason you are seing distorted mesh. $\endgroup$ – Black Chess King Aug 18 '18 at 15:36
  • 1
    $\begingroup$ If you have a mirror modifier it should be on top of the modifier stack $\endgroup$ – Denis Aug 19 '18 at 0:20
  • $\begingroup$ Could you upload your .blend file on blend-exchange.giantcowfilms.com so I can check and try to help you? $\endgroup$ – Tak Aug 24 '18 at 12:33
1
$\begingroup$

Actually, I think I know how to fix. I still have the mirror modifier on the mesh, as in I haven't applied it. Would that be the issue?

$\endgroup$
  • $\begingroup$ Yep, it was because I didn't apply the mirror modifier before adding the armature. Oops $\endgroup$ – AlfieC Aug 26 '18 at 12:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.