0
$\begingroup$

I have crated a wall of bricks. How can I bake it into the plane texture (not Normal maps just texture)? Simply i need to be able to bake all selected geometry with materials etc into one texture image.

$\endgroup$
1
$\begingroup$

You can put an orthographic camera in front of the wall (with line of sight perpendicular to the wall surface), scale the camera resolution and the orthographic scale to fit it and render it as an image.

$\endgroup$
  • $\begingroup$ Yes, that was the simplest thing i decided to do first. Even not camera rendering, just viewport in render mode :P $\endgroup$ – wooden_coder Aug 17 '18 at 17:54
3
$\begingroup$

There's An Easy way to Bake a Normal Map from High Poly Mesh (Your Wall) To a low poly simply a cube.The first thing you would have to do. Is place High Poly Mesh in First Layer & Lowpoly in Second.

  1. I hope you'd be using Cycles Rather than Internal its just a slight difference.

enter image description here

  1. In UV Image Editor Click for Image > New Image. Select a relation accordingly (make Sure it will be the power of 2) The Higher Resolution will give better Result.

enter image description here

Black Image Should Appear

  1. Select the Both Mesh High-Poly (Inactive) Low-Poly (Active). Select High Poly First & Lowpoly then(so High Poly will be inactive & Lowpoly Active) (Remember with Both layer Active).

enter image description here

  1. Last one Open Node Setup add a material for the Mesh (if it don't have one). Add Texture Node Don't Connect this node to the shader instead browse the Black Image which was created in UV Image Editor.

enter image description here

Bake It. (I will Edit the answer & will Post the Result later. I was in a Hurry) Sorry :(

For Any Further Video Detailes Checkout BlenderGuru Tutorial

$\endgroup$
  • 1
    $\begingroup$ Thanks, man. Generally you were right, but if you want to make it work you need additionally: 1) Add materials with image texture node not connected to the shader. Could be the same material. Otherwise you will receive an error. 2) When baking you need to select checkbox "Selected to active" or it woudl just bake two meshes one by one separately. That worked for me. $\endgroup$ – wooden_coder Aug 17 '18 at 17:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.