2
$\begingroup$

I was making a house in blender using a tutorial. I have not messed with the settings I have only ever added some addons. Today when I went on blender and tried to extrude a circle it did not work and gave me a really long error message. I reset my factory settings and reinstalled blender it still didn't work, so I looked in input just in case it was something to do with that but the whole input box is black. I also checked to see if the same thing as happening on the steam version of blender nothing had changed.I installed a beta version of flip fluids from GitHub but it had lots of python files so I installed all of them, it doesn'tenter image description here show up as an addon though.

first part of error message

enter image description here

second part of error message enter image description here input boxenter image description here

my addons.

Thank you for your help!

(edit: everything is fine on blender 2.80)

$\endgroup$
2
$\begingroup$

I expect that the copy of flip fluids wasn't installed right and is causing this issue. The flip fluids addon found on github is not a simple python addon that can be copied into place, it needs to be compiled for the target system before installing.

As you have reinstalled blender, the issue would likely be in your user settings. Find the USER path for your system and move or rename the folder with the version number (2.79) to say 2.79-bad. This will prevent blender from loading anything in there.

Once blender starts without any user config files, you can try replacing some files to try and restore to where you were before the issue. In the config folder, try replacing the startup.blend, userpref.blend and bookmarks.txt. Inside the scripts, you could try replacing some other addons you may have installed if you know they belong to an addon that you can't find the original files for. If you do this a couple of files at a time you can identify any that cause the issue.

$\endgroup$
  • $\begingroup$ THANK YOU! It worked! I just renamed the file and it started working again. Thank you! $\endgroup$ – Arthur.M Aug 14 '18 at 7:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.