1
$\begingroup$

I'm new to Blender. I've watched some tutorials on adding an image as a plane, but it is not working for me. Not sure what I'm doing wrong.

I have activated the add-on. I select "add image as plane" from the file menu. I select the file I want to import. These are the settings I'm using:

enter image description here

enter image description here

When I hit the button to import the image it goes back to the project, but there is no plane, no image. I doesn't change anything. I've tried looking in all views, top, front, etc. I've tried in both ortho and perspective views. There's nothing there.

What am I doing wrong?


I'm using version 2.79b on windows 10. The file I'm trying to import is a .jpg, 207kb, I've tried it as a .bmp also.

$\endgroup$
  • 1
    $\begingroup$ There should be a plane. Did you look for it in the Outliner? Deleting the addon from %appdata%\Blender Foundation\Blender\2.79\scripts\addons and reinstalling it might help. If it doesn't, could you check for any error messages in the Info panel (drag the main Blender's header with 'File', 'Render', 'Window', 'Help' menus down to see it) or in the console(Window->Toggle System Console)? $\endgroup$ – Martynas Žiemys Aug 13 '18 at 5:14
  • $\begingroup$ @MartinZ I don't see it in the Outliner. The System console just has the following Read prefs: C:\Users\tommc\AppData\Roaming\Blender Foundation\Blender\2.79\config\userpref.blend found bundled python: C:\Program Files\Blender Foundation\Blender\2.79\python $\endgroup$ – Tom Aug 14 '18 at 1:39
1
$\begingroup$

Can you insert other objects, or is it only the plane that doesn't appear in your project? Also, as stated above you can always look for your plane in the Outliner (file browser in the upper right corner of the Default Blender view) for your imported plane. If it is in your outliner, select it and press "." to teleport to it. If it isn't, it may be a corrupted project file or plugin; in that case, simply start up a new project and see if you can import an image as a plane there instead.

$\endgroup$
  • $\begingroup$ I was able to add the image as a background image, but that doesn't seem to do what I want, really. It is a new project page. It's the first thing I tried to do. I'll try re-installing the plugin, although I'm not exactly sure how. Do I just delete the file then go back into options and recheck the box or do I need to find the file online first? $\endgroup$ – Tom Aug 14 '18 at 1:44
1
$\begingroup$

Ok, I solved the problem, so I decided to just add an answer to say what I did.

I don't know what was wrong trying to add the .jpg or .bmp files, but I opened it in Paint and saved it as a png. The png file imported just fine.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.