0
$\begingroup$

This is a two part question

My texture in viewport mode looks very different from my texture in rendered mode. I used the color picker to select my texture and used that color for materials in the face. Now they just don't gel together when rendered.

My mesh with texture in viewport My mesh with texture in viewport My mesh with texture in rendered view enter image description here

So first question is why is my texture showing up so different when rendered?

Second questions is, is there a way to view both the texture and the material at the same time through the viewport?

$\endgroup$
  • $\begingroup$ Blender Internal or Cycles? $\endgroup$ – gandalf3 Aug 12 '18 at 7:07
  • $\begingroup$ Blender internal is blender render?!?! I've tried both render and cycles. These pictures are in blender render $\endgroup$ – Martin Marino Aug 12 '18 at 7:15
  • $\begingroup$ Yes, we tend to call it that in an attempt mitigate confusion.. In BI (Blender Internal, Blender Render) the process for assigning a texture to a material is separate from assigning a texture to a face (that is, what textured view shows). This might help: blender.stackexchange.com/q/1750/599. Also try switching to "Material View" via the dropdown with the sphere icon in the 3D view header (the bar along the bottom). $\endgroup$ – gandalf3 Aug 12 '18 at 7:35
  • $\begingroup$ I tried what it said in the link you posted. I switched from generated to UV and selected the auto generated UV map. But I think I'm having a different issue now that I look at it again. In texture mode I'm getting the top texture. In render mode it's rendering a different texture in my list for some reason. $\endgroup$ – Martin Marino Aug 13 '18 at 3:34
  • $\begingroup$ I think you must have checked 'Simplify' option. It can be found under Properties ->Scene -> Simplify. $\endgroup$ – AshKB Aug 17 '18 at 16:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.