completly newb here.
I need to construct some primitives for my ParticleSystems in Unity3D, but i have issues with UV maps. There is some mesh like a hemisphere

I need to put textures on this sphere, like this one

I just select all entire mesh by (A)>Unwarp, so its create default UV map, but this one is not much correct, like some distortion on top and not clear on bot.

Trying to google how to apply UV maps, but there is a lot of tutorials for hard-constructed mesh/texture but not a for simple one.

What i need is simple primitives and use non-unique textures for them correctly, would be nice if you have some tutros or w/e for learning.

up vote 0 down vote accepted

Weird that you have this result because with a simple UV Unwrap> Unwrap, it's automatically good, I just redesigned your texture so that I have a higher resolution but that's all. Maybe you have forgotten to give your object a Subdivision modifier, it will make your sphere smoother.

enter image description here

here is what it gives without the Subdivision modifier:

enter image description here

  • Thx for respond. Yes, "Subdivision modifier" was added before i create UV map. I guess reason of this "corrupted" UV map was my mesh wich is not exactly hemisphere, here is image imgur.com/4WISCSt When i create a real hemisphere this texture works correct (Unfortunately i was need exactly my mesh, not hemisphere). imgur.com/JohmD8Q – KhaadiR Aug 11 at 12:53
  • my object is not an hemisphere as well so it's not the problem, it must be something else, are you sure you're making a simple unwrap (and no seams)? – moonboots Aug 11 at 13:18
  • also, have you enabled the eye and camera icons of the Subsurf modifier? – moonboots Aug 11 at 13:27
  • I'm an some special sort of idiot. When i create "Subsurf" i didnt click APPLY at all. Now my mesh with correct UV map, thx. (idk but when i export FBX for unity that was smooth mesh like with "Subsurf", so i didnt pay attention i guess, absolutly my fault). – KhaadiR Aug 11 at 14:42

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.