I was rigging my character, I first did the central bones, then added the bones to the right (left bones of the character) and duplicated and mirrored them in the X axis (for making the right bones of the character). The problem is that in Pose Mode the yellow bones in the arms have different positions and rotations even though they have no transformations. Armature in Pose and Edit Modes As you can see in the gif I provided, the positions and rotations are the same in Edit Mode but not in Pose Mode, even after "Clearing All".

I haven't found anything different between the affected bones (not constraints, nothing (and that is as expected, given that they're merely mirrored duplicates)). Any idea of what could be wrong?

Thanks in advance.

Edit: This has something to do with the IK, because when I turn it off for both arms get the same roll values. I've te with your IK's bone Constried creating a rig from start but the same problem happens again.

Edit: I've deleted the rig first shown here. Since you asked, I've recreated a similar rig with the same problem and here are the IK constraints. Left Arm IK Right Arm IK

  • Can you upload a picture with your IK's bone Constrain? – Ryo Aug 15 at 4:55

Your Answer

 
discard

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.