enter image description hereIn the process of Resculping from Grayscale to 3D Mesh With Blender, when i do an Unwrap on the left window (3D View) I get a grid on the right window (UV Image Editor) , but the grid doesn't ocupies the whole picture, just occupies the lower part of it.

What should I do solve the problem? Regards, Damir

[![enter image description here][2]][2]

bumped to the homepage by Community 2 days ago

This question has answers that may be good or bad; the system has marked it active so that they can be reviewed.

  • 1
    Try to apply scale and rotation before unwrapping (CTRL+A). If doesn't help, than rotate workspace 90 deg (keypad numbers 4 or 6) and unwrap "project from view (bounds)" – Serge L Aug 10 at 12:30
  • Have you tried to do a smart unwrap? – Marty Fouts Aug 10 at 21:30

Procedure that caused the problem:

1. Creating object (Plane)+ its dimensions

In 3D View; Object Mode: Add\Mesh\Plane Dimensions: x=82; y=313; z=0

2. Defining properties

In Properties: Define material (doesn’t matter which one), Define texture - by opening (importing) the picture (.jpg) file.

3. Adding Second window – UV Image Editor

Splitting area, so that I can see two working windows. A new window is located on the right side. Switch to ‘UV Image Editor’.

4. The picture

Import the same picture that was used for texture into the new (UV Image Editor) window.

5. Creating a mesh

Going back to left window (3D View window), Change mode to ‘Edit mode’, Tools\Mesh Tools\Subdivide Repeat ‘Subdivide’ 3-4 times. Note that the cells of the mesh that appears are rectangular shaped!

6. Unwrapping

Mesh\UV Unwrap\Unwrap

7. The Problem

That’s the point where the mesh is also shown over the picture (in UV Image Editor), but it doesn’t cover the whole picture. That was the main problem! Note also that the cells of the mesh over the picture are square shaped, while the cells of the mesh over the object (in 3D View) are rectangular shaped! It is not possible to reach the goal by changing dimensions or scale of the object (left window\Transform\Scale or Dimensions), one can’t obtain the goal – i.e. cover the whole picture.on the right window with the mesh!

Correct procedure:

1. Creating object (Grid)

In 3D View; Object Mode: Add\Mesh\Mesh Add Mesh\X Subdivisions = 82 Add Mesh\Y Subdivisions = 313 Dimensions: x=82; y=313; z=0

Note that Grid object type allows mesh to be subdivided unequal number of times on x and y axis, unlike the Plane object, that allows just equal number of subdivisions on both axes! Thus, using Grid, one can obtain almost square shaped mesh on a rectangular (82 by 313 points) shaped Grid object!

2. In Properties:

Define material (doesn’t matter which one); Define texture - by opening (importing) the picture (.jpg) file.

3. Adding Second window – UV Image Editor

Splitting area, so that I can see two working windows, A new window is located on the right side, I switch it to ‘UV Image Editor’.

4. The Picture

Import the same picture that was used for texture into the new (UV Image Editor) window.

5. No need to create a mash here! It was already created In 1.

6. Unwrapping

Mesh\UV Unwrap\Project from View (Bounds)

Note that the unwrapping here is done using a different option – ‘Project from View (Bounds)’. That’s the point where the mesh is also shown on the right picture (UV Image Editor), and now it covers the whole picture! Problem solved! Correct Mesh by using the Grid object instead of Plane object.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.