I am trying to modify a model's UV map in order to fit it whole inside a single texture, but I keep getting the "Circular reference in texture stack" error. After trying every single thing I found on the Internet (including this StackExchange answer), I can't seem to get rid of the error, even though I had been able to do it before after fooling around with the model for a bit.

The steps I follow are:

  1. Import the model
  2. Scale it down
  3. Delete the new file cube
  4. OPTIONAL: the model I am importing has 4 materials, without any associated textures. I can add new textures to each material and open the appropriate Image files, but whether I do or not, it does not change the result.
  5. Open a panel with UV edition view
  6. Select the model
  7. Press Tab to open Edit mode. All UV vertices are selected.
  8. Using the UV view panel, I create a new Image, titled "bake"
  9. I go to the Render tab of my model, then select "Texture" in the Bake section, then press Bake.
  10. A few vertices manage to render inside the Image named "bake", but then the "Circular reference in texture stack" error pops up.

Things I have tried:

  • Unchecking every Texture inside every material.
  • Placing the target Image inside a Texture inside a Material inside the model, alongside the other four. Then, tried unchecking all non-target Textures, then unchecking the Target texture, then unchecking all Textures.
  • Deleting some Materials, and leaving only one.
  • Deleting ALL Materials. This is the only option that does not trigger the error, but it's obviously not what I want.

It's my first time attempting to use Blender for something serious, so I am probably doing something wrong, but I am overwhelmed and can't really understand what's going on despite the docs.

Does anybody know what might be preventing the baking process on something that doesn't even have any Textures associated?

  • $\begingroup$ When baking in cycles you will have to have a unconnected blank image texture SELECTED in the cycles materials. This is where Blender bakes to.. have you followed this step? also you could check this video, which still is useable as far as I remember youtube.com/watch?v=sB09T--_ZvU $\endgroup$ – sorenfroststaal Aug 10 '18 at 10:09
  • $\begingroup$ @sorenfroststaal I was using the standard Blender Render, though. I followed some other videos, but it did not help with the issue. Should I try with the Cycles renderer? $\endgroup$ – HorriblePerson Aug 10 '18 at 22:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.