0
$\begingroup$

When im painting im getting some gray lines on the paint.

When i fill the color i dont get any lines

But when i paint with color with the brush i get those lines.

enter image description here

How to clean those gray color lines. Any suggestion. Thanks

$\endgroup$
  • $\begingroup$ Maybe clean up the basemodel using edgesplit modifier? $\endgroup$ – WhatAMesh Aug 9 '18 at 8:28
  • $\begingroup$ @WhatAMesh base model is from makehuman addon and what you mean clean up? $\endgroup$ – atek Aug 9 '18 at 8:32
  • $\begingroup$ Im no expert but I could imagine that there are sharp edges that make those weird lines. With cleanup I mean smooth out $\endgroup$ – WhatAMesh Aug 9 '18 at 8:37
1
$\begingroup$

This issue is caused due to the UV edges touching both the black background and the green paint It also helps when you use a mipmap as the resolution decreases.

To fix this you need to draw a bit over the UV border. This creates something like a padding.

Another way would be to match the background and the colored areas as close as possible.

Additionally a clean UV unwrap would also help a lot as it reduces the ammount of these edge areas.

$\endgroup$
0
$\begingroup$

You are getting an effect at the border of your paint dabs - a solid area fills correctly, but at the boundary the paint seems to form a dark edge on top of the same color. This most often happens when using a color not exactly the same as the one you are painting into. If you are using a fill tool in the 2d UV/Image Editor, be aware of the thresh hold settings as this affects the paint boundary.

$\endgroup$
0
$\begingroup$

I see your template has some grey lines in it, I use gimp, and if you do, then you can just select the grey and paint it green instead. I took your image and traced two shapes that are the same, minus that it is upside down on the faces versus the template. If you paint over the grey, and then put that image (no grey lines) in the image texture node, it should workenter image description here

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.