0
$\begingroup$

This question already has an answer here:

enter image description here

I can't figure out why my scene is still so noise after I optimized the scene / lighting settings.

I have the following settings:

1. Sampling:

  • I increased the Sample size to 2056
  • I'm clamping direct and indirect light at value 7.0

Sample Settings

2. Lightpath:

  • Caustics are on.
  • I use the preset Full Global Illumination
  • Lowering the diffuse does not help the gain in the render.

enter image description here

3. Portals & Area Lights:

  • The windows have Portals on them.
  • Each Portal also have an area lamp on them with a strength of 25 to create some more light.
  • Multiple Importance is enabled.

enter image description here

4. Sunlamp:

  • The scene has an Sunlamp with a strenght of 250.
  • Multiple Importance is enabled.

enter image description here

5. World Settings:

enter image description here

*Note: I don't use the denoiser because I'm rendering on a render farm that splits the render in parts. So the denoiser does not work. *

Update: Turning off caustics did not improve the render.

Question is: Can I reduce the noise in other ways then increase the sample size?

$\endgroup$

marked as duplicate by Leander, Scott Milner, Denis, batFINGER, p2or Aug 11 '18 at 14:52

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • 1
    $\begingroup$ I was under the impression that caustics can ADD noise, I would try turning them off. $\endgroup$ – icYou520 Aug 8 '18 at 22:32
  • $\begingroup$ maybe try using this glass set up for your window. blender.stackexchange.com/questions/107018/… that way the lights doesnt have to fight with the glass. $\endgroup$ – icYou520 Aug 8 '18 at 22:34
  • $\begingroup$ @icYou520 I can try, but I think they cause Fireflies not the noise right? At least that is what I remembered.. There is no glas in the window. $\endgroup$ – S.Visser Aug 8 '18 at 22:39
  • $\begingroup$ hmmm, thats true, I just almost always turn caustics off because Cycles can't do them anyway so it just adds to render time and it always seems to give me ugly results. The only other thing I can suggest is up the render samples to 3000 or so. $\endgroup$ – icYou520 Aug 8 '18 at 22:46
  • $\begingroup$ moar samples! On your local machine select an area, set the Border render and just keep upping your samples until you get the result you want then untick Boarder and upload it to your render farm. $\endgroup$ – rob Aug 10 '18 at 10:43
2
$\begingroup$

The "correct" way to reduce noise is to increase the sample size. You mentioned that this didn't completely solve the problem, but I would use the largest sample size you can reasonably afford (within your time constraints, patience, etc.). Also, I've heard that it's best to use powers of 2 for sample sizes. So maybe try 2048 instead of 2056...

Additionally, the latest versions of Blender have the denoise feature, which works better than an external noise reducer, because it has access to data not present in the final image. It will further reduce the noise in your image.


Regarding portals:

They work best when most of the light in your scene comes indirectly from the environment through small windows. If your scene has large windows, uses many lamps or contains lots of complex materials, portals might actually slow the render down and introduce more noise.

(https://www.blenderguru.com/tutorials/using-portals-accelerate-render-times)

It seems that your windows could qualify as large (though you don't seem to have extremely complex materials), so maybe try a render without portals, and comparing the two in terms of noise and render time. I don't know which way will work best for your scene.


Finally, you could cheat and make the blinds in the windows invisible to all rays except camera rays (the opposite to this answer). This will make the result less physically accurate, but it will let in more light, and reduce the number of bounces light needs to get inside, resulting in a brighter and less noisy picture.

$\endgroup$
-1
$\begingroup$

Try changing the Ray Visibility Settings(Objects Panel) of the windows in the scene.

$\endgroup$

We're looking for long answers that provide some explanation and context. Don't just give a one-line answer; explain why your answer is right, ideally with citations. Answers that don't include explanations may be removed.

  • 3
    $\begingroup$ Hi. Would be good if you could add more information, such as which settings they should change and why. $\endgroup$ – Ray Mairlot Aug 10 '18 at 14:58

Not the answer you're looking for? Browse other questions tagged or ask your own question.