0
$\begingroup$

When I place my fbx file in unity it's only visible from the bottom, when I look at it from the top I can't see anything. How can I fix that?

This is how it looks in blender: https://imgur.com/a/F7uPO38

This is how it looks from the bottom in Unity: https://imgur.com/a/yAH2bRy

This is how it looks from the top in Unity: https://imgur.com/a/vEuQsPb

| improve this question | | | | |
$\endgroup$
  • 1
    $\begingroup$ Include screenshots inline into the question body please; see how; if link for the screenshot goes down (e.g. you remove images from Imgur) this question won't be quite clear any more. $\endgroup$ – Mr Zak Aug 8 '18 at 12:27
2
$\begingroup$

Most likely, the normals are facing the wrong direction. Unity doesn't render the backside of polygons, while blender does.

Try flipping the normals around. The reference for doing this is here.

| improve this answer | | | | |
$\endgroup$
  • $\begingroup$ To spot problems like this early you can enable backface culling in the 'N' panel (toggle open with N key). Then your mesh will display similarly to game engines. To make your mesh visible from both sides, you can also try the solidify modifier. $\endgroup$ – Tavi Kohn Aug 8 '18 at 14:07
  • $\begingroup$ Please include some details in the answer itself on how to flip normals, just in case that manual link is unavailable at some point. $\endgroup$ – Ray Mairlot Aug 8 '18 at 15:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.