0
$\begingroup$

So I start with a normal cube > I Extrude and it doesn't work right ( Grey faces and missing faces ) I try to move a face/vertices with G and right click but it selects some sort of ghost vertices. Help I can't solve this and it's making me want to give up Blender. I tried looking for solutions but it seems like it's a bug.

The Problems that happen

$\endgroup$
4
  • $\begingroup$ Ok, what version of blender are you using? Have you tried deleting the cube and starting over? It seem like you've got duplicated vertices that are conflicting. $\endgroup$
    – VorTechnix
    Aug 7, 2018 at 2:20
  • $\begingroup$ @TechTornado I've tried starting over and restarting Blender. I'm using the version on Steam so it's most likely the recent version. Is there a way to fix this? $\endgroup$ Aug 7, 2018 at 2:29
  • $\begingroup$ To clarify: have extruded successfully, using prior or other versions of blender? $\endgroup$
    – batFINGER
    Aug 7, 2018 at 7:50
  • $\begingroup$ Yeah it used to work fine $\endgroup$ Aug 7, 2018 at 19:17

1 Answer 1

1
$\begingroup$

It doesn't look like a bug to me. There are 3 types of selection modes in blender; Vertex, Edge and Face. You have to select them according to your requirements. If you select any of them and press 'E' to extrude, it extrudes along the normals by default. If you want, you can constrain your extrusion to a specific axis by pressing 'E' to extrude and then X, Y or Z for x, y and z axis respectively.

The second problem you mentioned is shading problem according to me. After you've finished your extrusion and modelling, select the whole mesh in edit mode by pressing 'A' key and then recalculate the normals.

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .