1
$\begingroup$

I'm trying to make a animation where, from a clean slate, more and more objects are to appear one after another. I have seen a method where you make the material transparent, but this doesn't seem like a good way to do it... Since I have about 100 object that I want to animate, that all have the same material, I don't want to make a duplicate of the material for every object.

Do you have a better solution for this problem?

Best regards /John

$\endgroup$
  • $\begingroup$ When ever I have had to do this I simple animate the location from on-off screen over 1 frame. $\endgroup$ – rob Aug 6 '18 at 10:54
  • $\begingroup$ Only use rob's method, if you aren't using motion blur. $\endgroup$ – Leander Aug 6 '18 at 11:17
  • $\begingroup$ an easy way could have been to create an animation between a Diffuse and a Transparent shader, then in the NLA move the Strip of each object to change the moment they appear, but it looks like, unlike a move Strip, you can't change a Shader Strip position of an object without changing it for all the objects sharing the same Strip, am I right? $\endgroup$ – moonboots Aug 6 '18 at 11:48
4
$\begingroup$

If you don't need your objects to appear gradually:

  1. Select your object, go into the Outliner, deactivate the Show In Renders option (camera icon) and create a keyframe (i).

  2. Now in the Timeline move to the frame where you want your object to appear, go into the Outliner, reactivate the camera icon and create a new keyframe.

  3. If you duplicate your object, you just have to move the 2nd keyframe in the Dopesheet to change the time of its appearance.

You can also keyframe the Show In Viewports option (monitor icon) so that you can see in the viewport what will happen in your render.

These 2 options, Show In Renders and Show In Viewports are also available and keyframable in the Properties panel > Object > Visibility.

$\endgroup$
  • $\begingroup$ I followed the instructions but failed because, the pointer must be over the visibility, "eye" icon when you create the keyframe, otherwise it will assume you are animating translation of the object and you will not be given the choise for visibility. At least, so it is in Blender 2.8x $\endgroup$ – Christos Jun 8 '20 at 11:13
  • $\begingroup$ hello, not sure to understand, in my 2.8 version you can't keyframe the viewport visibility (eye icon). There was another way to animate the visibility through the Shade Editor, that would have been more relevant to the question but I can't put my hand on it... $\endgroup$ – moonboots Jun 8 '20 at 11:24
  • $\begingroup$ @mooboots You are right I was trying out the Render "camera" icon, that works. The visibility in viewport can indeed be accessed from the Properties panel > Object > Visibility. It effects the "monitor" not "eye" visibility. Be sure to set the value from the tickboxes in the Properties or Timeline and not from the Outliner, because it won’t “stick”. $\endgroup$ – Christos Jun 8 '20 at 11:49
  • $\begingroup$ oh ok I see that viewport visibility only works in the Properties panel, not optimal though, weird, anyway I guess it's rarely useful... $\endgroup$ – moonboots Jun 8 '20 at 11:58
  • $\begingroup$ It works, I'm fine. After I had ticked selection inside the object properties, I tried to change the keyframe status from the Outliner, THAT doesn't work. You need to do all from the Properties. My bad $\endgroup$ – Christos Jun 8 '20 at 12:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.