0
$\begingroup$

I have 2 GeForce GTX 750 Ti GPUs in my system (no SLI), the first has 3 monitors on it and the second has nothing connected. Under the system tab in user preferences I selected the second GPU to be the only compute device. However, when I click render it doesn't seem to be doing anything on the second GPU, only the first. My situation is similar to this question but it didn't provide me with an answer. Multiple graphics cards. Is there a way to designate one as compute device only?

Here's a screengrab of the preferences and the GPU load using TechPowerUp GPU-Z while a render was going. The monitor is showing that there is no load on the GPU when there should be something. I've tried switching which GPU was selected, even selecting both and got the same result, it never uses the second GPU.

Is this expected behavior or maybe a bug? Is there another setting I need to look at changing?

Thanks for the help. enter image description here

$\endgroup$
1
$\begingroup$

It shows GPU core clock at 135MHz. There is something wrong with that. Usual clock speed of GTX750TI is 1020MHz. It could be that for some reason the driver crashes and it switches to some sort of a safe mode. Updating drivers would be first thing to do. I would try using it just after rebooting the PC. If it works just after a restart then it will be clear that the problem is indeed with the driver crashing. The GPU could be overclocked too much or it might be overheating or it might not be able to get enough power.

$\endgroup$
  • $\begingroup$ I updated the driver to the latest version (it was only 1 version behind for both GPUs) and now it looks like it's being used. My usage and clock speeds spike when I render on it. It still sits at 135 MHz when idling though, maybe that's normal? I will continue testing over the next few days. Thanks for the help! $\endgroup$ – ry_ol Aug 11 '18 at 21:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.