0
$\begingroup$

For some reason, this hollow cylinder gets textured differently than a normal cylinder, and it's auto generated as a column, just like doors and windows. I like the way it looks better than texturing a normal cylinder, but it stops looking good at one point and the texture seems to clip.

enter image description here

You can see in the left column that at the bottom, it's well textured, but as it goes up, it becomes weird. It's a poliigon texture I applied with nodes. What can I do to fix it, or achieve a result like the bottom part of the column?

$\endgroup$
2
  • $\begingroup$ How does your node setup looks like? How did you unwrap your cylinder? etc... $\endgroup$
    – moonboots
    Aug 3 '18 at 15:11
  • $\begingroup$ This is the node setup: prntscr.com/keba06 I just went to edit mode and pressed unwrap. $\endgroup$
    – Skyleft
    Aug 3 '18 at 15:17
-1
$\begingroup$

In the Edit mode delete the top and bottom faces. As we do not need extra faces here.

With the edge selected. Select the top and bottom and any center edge with shift select

With the edge selected press Ctrl+E and select Mark Seam

Now Press A to select all Faces. Press U and select Unwrap

Drag and make a new window -> UV Editor

Click on the new button and navigate the image.

Now in the material tab -> New and select the image from drop down

Note : Before you process the above steps. Press Ctrl+A select Rotation and Scale

enter image description here

Click on the small dot -> image texture

enter image description here

Then click the drop down here (find the same texture you have used in UV editor)

enter image description here

$\endgroup$
9
  • $\begingroup$ I can't select the top, bottom and a center edge. How do I do that? I'm pressing alt+select to select all the top edges, so how do I select the bottom ones at the same time? $\endgroup$
    – Skyleft
    Aug 3 '18 at 15:36
  • $\begingroup$ Go in wireframe mode or mean time Press H to hide floor and ceiling $\endgroup$
    – atek
    Aug 3 '18 at 15:43
  • $\begingroup$ That's not what I meant. In your gif, you select the top and bottom circles of the cylinder, but I can't do that. When I try to select it, I just select a single vertex and not the circumference itself. $\endgroup$
    – Skyleft
    Aug 3 '18 at 15:52
  • $\begingroup$ I got that to work. Now, when I go to the materials tab, how do I select the image? Where's the drop down you mentioned? When I press on New, a bunch of options and settings show up. $\endgroup$
    – Skyleft
    Aug 3 '18 at 16:26
  • $\begingroup$ @Skyleft check the answer edited $\endgroup$
    – atek
    Aug 3 '18 at 16:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.