I have uv layout like in the image. I just want to force it to occupy the empty area in the right (Right now it's only cover the left area) . How can do this ? but keep the overal rough shape without making all become square. So basically just like to scale it X direction but do it automatically to fit the space.


blend file : https://drive.google.com/drive/folders/18DxOHq_wxzXHrv7gVvsswGNwl8D-4Lwe?usp=sharing

enter image description here

  • $\begingroup$ Have you tried Scale to Bound? The option is available just after your unwrap, on the bottom of the left menu (activated with T when you are in 3D view) $\endgroup$ – moonboots Aug 3 '18 at 11:41
  • $\begingroup$ @moonboots i can't find 'scale to bound'. There's similar setting but not in unwarp. It's in smart uv project , called "stretch to UV bound". But using smart uv project , it will break the island, i'm not getting a single continuous island. $\endgroup$ – andio Aug 3 '18 at 13:05
  • $\begingroup$ so I guess you've tried wall the options of Unwrap? Conformal instead of Angle Based and unclick the Fill Holes option? $\endgroup$ – moonboots Aug 3 '18 at 13:57
  • $\begingroup$ @moonboots i update my post , i've included the link to the .blend file. Pls check it out. $\endgroup$ – andio Aug 3 '18 at 14:18
  • $\begingroup$ if you go in top ortho view, enter in Edit mode, press U > Project from View, and click on the Scale to Bounds option on the bottom of the T menu, you don't get what you want? $\endgroup$ – moonboots Aug 3 '18 at 14:34

Choose Top Ortho view, enter in Edit mode, select the whole mesh, press U > Project From View, and click on the Scale to Bounds option on the bottom of the left menu (displayed with T), or choose directly Project From View (Bounds).

enter image description here


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.