as a title says, I have a problem when importing, mainly, animations to unreal Engine 4. The main problem is, the animation is scaled differently to the character. When I import the animation I also get the warning: "Imported bone transform is different from original. Please check Output Log to see detail error".

I have searched for many many solutions from people with similar problems, but so far I cannot find a solution that works. I am at a loss here.

Here are the export setting I use for the mesh+rig:

enter image description here




For the animation, I select only the armature and export it with selection only, same settings as above, except for animations:


And when Importing to Unreal Engine 4, the character:


And the Animation:



1 Answer 1


I had the same issue.

With me, the cause was that I had some objects selected (in Blender) that were not part of the animation. Exporting only "selected objects" (as per FBX export menu) that meant that my erroneously selected mesh was also selected - and was interpreted as a separate 'skeleton' in UE4. This 'skeleton' could obviously not be matched and gave the error ""Imported bone transform is different from original" on import.

Correcting the selection of meshes before export in Blender solved the issue in this case.


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .