I rendered a 10 second animation with 230 frames, but when I uploaded it into the video sequence editor in the exact same blend file it got stretched to 6 minutes making it off sync with the music. audio on the bottom strip and video on the top strip

As you can see the video is massive compared to the audio strip

I think I have to adjust the frame rate (which I do not know how), but shouldn't the lengths be the same since it's made in the same blend file?

  • Did you render it as a .mkv in an older version of Blender? I seem to recall that some Matroska exports were broken but are good in recent builds. Try exporting again if you can with an alternate codec. You really should render as frame sequences before delivery anyway ;-) – 3pointedit Jul 30 at 13:07

you can either add an Effect Strip/Speed Control or re-encode the video

ffmpeg -i yourfile.mkv -c:v libx264 -crf 23 -pix_fmt yuv420p -c:a copy -r 24 newfile.mkv

Or try matching the frames per second in the Blender Render settings before you add the video in VSE.

I always use the ffmpeg command as matter of course.

Hopefully Blender 2.8 will have a new ffmpeg library and this will go away.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.