1
$\begingroup$

I am using daily builds of 2.79 version and can't find Shadows checkbox that has been here some versions ago:

enter image description here

Ways of doing it on per-object basis are not acceptable, need single-click solution like in BI or older Cycles.

EDIT: Forget about picture above, I've mixed up it with BI settings. In Blender Internal it looks like this:

enter image description here

$\endgroup$
3
  • 1
    $\begingroup$ I see this option in my 2.79, but I don't know how it works, nothing happens when I disable it. You can disable the Cast Shadow option of your lights but I suppose it's not what you want. $\endgroup$
    – moonboots
    Commented Jul 28, 2018 at 11:54
  • $\begingroup$ As @moonboots said in my 2.79 I do have the same button but I see no difference either. What should happen, if you ticked it? If the shadows are not masked, where is the light that's brightening the shadows coming from? If it looks like the shadeless mode in blender internal, why don't you open-GL render it in textured mode? $\endgroup$
    – quiliup
    Commented Jul 28, 2018 at 16:09
  • $\begingroup$ Well, it seems I mixed up this option with similiar checkbox of Blender Internal, which is doing exactly what I need from Cycles. Open GL is good, but still need more than that. P.S. This Shadows button is now "checked" by default and will be removed in next version and dauly builds. $\endgroup$
    – Serge L
    Commented Jul 28, 2018 at 16:30

1 Answer 1

2
$\begingroup$

That Cycles checkbox only disables transparent shadows, hence it's location next to the transparent depth controls. It has no affect on regular shadows from material without the transparent BSDF, and even materials with the Transparent BSDF will still cast shadows with it disabled. Just without taking transparency into account.

There is no global control to disable shadows, you need to disable shadow-ray visibility on all objects. If you need to do it for a lot of objects, the following bit of Python will switch off the checkbox for all selected objects:

import bpy

for obj in bpy.context.selected_objects:
    bpy.context.scene.objects.active = obj
    bpy.context.object.cycles_visibility.shadow = False
$\endgroup$
3
  • $\begingroup$ Thanks for the script! But maybe you have a suggestion on how to take into account not only selected objects, but exclude those objects, which have already disabled shadows. So when I'll get shadows back (set to TRUE), they wouldn't appear on objects that shouldn't cast them. $\endgroup$
    – Serge L
    Commented Jul 28, 2018 at 22:11
  • $\begingroup$ The script sets the flag to false, regardless of its previous setting. It does not toggle the option. Is that what you're referring to? If not, I'm confused. $\endgroup$
    – JtheNinja
    Commented Jul 29, 2018 at 0:35
  • $\begingroup$ When there is a lot of objects, I doubt you would select them by individual clicking, instead select them all at once with A key. Unfortunately, this ends up in selecting objects with already disabled shadows along with others. So, they will get unwanted "True" value after returning shadows back $\endgroup$
    – Serge L
    Commented Jul 29, 2018 at 5:31

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .