0
$\begingroup$

This question already has an answer here:

My image texture looks like this: enter image description here

And yet when I try to add a transparent BSDF shader it doesn't work properly, and the result looks like this: enter image description here

I've tried many things; changing the BSDF color to black, adding the image texture to the fac, adding the image alpha to the fac, removing the normal map, changing the BSDF settings, and a lot more, but to no avail.

Here's my node setup at the moment: enter image description here

How would I go about removing the black void around it while not making the metal itself transparent as it is now? Thanks.

$\endgroup$

marked as duplicate by Duarte Farrajota Ramos, Scott Milner, m.ardito, batFINGER, David Jul 30 '18 at 12:10

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • 1
    $\begingroup$ Plug the alpha out into the fac of your mix shader $\endgroup$ – icYou520 Jul 27 '18 at 22:54
0
$\begingroup$

Try this setup. Under User Preferences, under the Add-Ons tab, one option is Import Images as Planes. This is based on the default setup, but with a metallic shader. This should work, but only if you use Cycles Render.Node Setup

Also, I see what you're trying to do with the image, and I know a way you can make the images look 3D from any angle through microdisplacement. To do this, link the image to the displacement input of the Material Output node. It is best to use a bump map for the purpose. If you got the image online, there may be one already made. Otherwise, use this tutorial at https://www.youtube.com/watch?v=c9Q6E59hVpU to create your own off of the original image using your own image editing software. Tell us how it worked.

Anonymous

$\endgroup$
  • $\begingroup$ I've tried that exact setup as I alluded to in the original post (Clearly I should have made this more obvious, as all 3 replies seem to think I did not.) and it still doesn't work. $\endgroup$ – Crashsune Jul 28 '18 at 22:11

Not the answer you're looking for? Browse other questions tagged or ask your own question.