1
$\begingroup$

I am using boolean through modifier.also use subdivision modifier on both objects. But why this shadow as shown on picture show up.i tried to simplefy sub modifier but no the result i wanted to.Mesh seems to screw up after boolean.

enter image description here

enter image description here

$\endgroup$
  • $\begingroup$ what if i want to smooth? $\endgroup$ – Dimitris Jul 28 '18 at 17:08
  • $\begingroup$ this simple, but best answer: - dont use booleans. As you can see in answer - correct mesh after boolean need more time than make it manually and you get worst result. If future, try not to use boolean and make your life simpler :-) $\endgroup$ – Shubol3D Jul 28 '18 at 18:35
3
$\begingroup$

Shading issues after booleans are really common, because after the boolean creates your cut-out or whatever, you end up with faces that don't have 3 or 4 sides (which blender prefers)... then if you're using smooth shading, blender doesn't always understand where you're trying to smooth out the transition between one flat surface and another.

One option is to create an extra set of faces all the way around the "cut", and then the shading issues will mostly happen between the original cut, and the new set of edges. They may not disappear entirely but they'll be smaller and less obvious.

It's also important to split apart those faces with 5 or more sides into 4-sided or even 3-sided faces.

Where to make the splits, determines how effectively you will fix the shading problems. Some splits can actually make it worse.

enter image description here

enter image description here

enter image description here

enter image description here

enter image description here

enter image description here

enter image description here

enter image description here

enter image description here

enter image description here

| improve this answer | |
$\endgroup$

Not the answer you're looking for? Browse other questions tagged or ask your own question.