0
$\begingroup$

In Blender 2.79, evenly distributing vertices using LoopTools only seems to work for meshes, not bezier curves. How would one do it for bezier curves? I have seen this post: How to evenly space vertices along several segments bezier curve but find the first solution too much of a workaround. The second solution does not work for me, because Blender does NOT place new vertices in the exact middle between existing vertices when subdividing a bezier curve (see screenshot) enter image description here

$\endgroup$
  • 1
    $\begingroup$ It shouldn't place vertices unevenly when you subdivide a bezier curve, it should place the new vertices exactly between existing vertices. $\endgroup$ – moonboots Jul 27 '18 at 12:27
  • 2
    $\begingroup$ Possible duplicate of How to evenly space vertices along several segments bezier curve Check my second answer there $\endgroup$ – Duarte Farrajota Ramos Jul 27 '18 at 13:00
  • $\begingroup$ @moonboots Somehow, it doesn't (see edited question). Could I have messed up any settings in Blender? I opened a new file for the screenshot. $\endgroup$ – Anne Morbach Jul 27 '18 at 13:27
  • $\begingroup$ @Duarte I have seen that post but find the first answer unsatisfying and the second answer does not work for me (see edited question). $\endgroup$ – Anne Morbach Jul 27 '18 at 13:27
  • 2
    $\begingroup$ @DuarteFarrajotaRamos Subdividing bezier segments in Blender places the points evenly in relation to the time parameter when moving along the curve. It does not take spacial distances into account. The fact it worked for you is only a coincidence and rare, it depends on the curve shape and how long the handles are. In general those segments are not even, the arch lengths between points differ. $\endgroup$ – Jaroslav Jerryno Novotny Jul 27 '18 at 19:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.