0
$\begingroup$

I'm modeling a mirror. I created this frame by extruding planes for the outside part and then connecting both holes from the front and the back. I used and applied a mirror modifier for the Y axis.

Everything looks good until I render the file, it shows a strange line as you can see below in the screenshot. I can solve this by using a Subdivision modifier but then I lose the sharp edges. Tried adding more edge loops and beveling but it seems I'm missing something.

Is there anything I can do to avoid these artifacts when rendering?

Top left image shows a weird sewing artifact when rendering.

$\endgroup$
  • $\begingroup$ have you tried recalculating normals in edit mode? You can also select the edges and increase their Crease value in the Edge data on the N-Panel so they stay sharp when you add a subdivision modifier. $\endgroup$ – Samir Rahamtalla Jul 27 '18 at 16:55
  • $\begingroup$ I tried recalculating normals too but didn't help. The other answer I got worked but I will try increasing the Crease value too and learn from this. Thank you :) $\endgroup$ – Christian M. Jul 30 '18 at 6:41
1
$\begingroup$

The problem is that you have activated the Smooth Shading option of the T menu, but your object is a low-poly mesh. If you try to smooth a low-poly mesh these strange artifacts can happen. It's true that you have given your object a Subdivision Surface modifier that is used to simulate a high-poly mesh, but you have disabled its Display modifier in Viewport, so the artifacts still appear.

You say that you did that because you wanted to have both smooth and sharp edges.

If you want to have a smooth appearance but at the same time keep some sharp edges, add some additional edge loops close to the angles you want to keep sharp. Here is how:

enter image description here

$\endgroup$
  • $\begingroup$ If I enable it it will make the object look smoother, but I'd like to keep its edges sharp. Thus I activated Smooth Shading to have a mor rounded shape without adding more edge loops. Is there a way to keep Smooth Shading activated and avoid the artifacts? $\endgroup$ – Christian M. Jul 27 '18 at 9:52
  • $\begingroup$ Thank you for such a detailed answer! That's exactly what I wanted. $\endgroup$ – Christian M. Jul 27 '18 at 10:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.