1
$\begingroup$

My Linux Mint version is 18.3 Cinnamon (64) bit

I'm using Blender 2.79b (Cycles)

This is the path where Gimp.desktop is located:

/var/lib/flatpak/app/org.gimp.GIMP/current/active/export/share/applications/org.gimp.GIMP.desktop

However, when I use the function Edit Images Externally in Blender I get the following error message:

Image editor could not be launched, please ensure that the path in User Preferences > File is valid, and Blender has rights to launch it

Please note:

  1. I've already saved the image to edit externally.
  2. I verified the path where Gimp is located.
  3. I accessed Gimp as root and changed all access values to: READ & WRITE. The execute box is also checked.
  4. I also saved the User Preferences in Blender.

This is not a duplicate because the similar question asked is about Windows whose OS is completely different from Linux.

Application Finder Result

To discover the real path where Gimp executable is, I was told by the Gimp Team that I must right click Gimp.desktop with a text editor.

$\endgroup$
  • $\begingroup$ It is somewhat important to realize that flatpak is a sandbox, and not just a new fancy package format: github.com/flatpak/flatpak/wiki/Sandbox $\endgroup$ – Michael Schumacher Jul 30 '18 at 9:16
  • $\begingroup$ The corresponding issue in the GIMP issue tracker is: gitlab.gnome.org/GNOME/gimp/issues/1946 - we are currently assuming that this might be a limitation on Blender's side, i.e. that it assumes the command to be a binary without any additional parameters besides the image file name. Could some experienced Blender users chime in there? $\endgroup$ – Michael Schumacher Jul 30 '18 at 13:23
  • $\begingroup$ I filed a bug with Blender as well, you can follow the situation here:developer.blender.org/T56158 $\endgroup$ – Miracles Happen Jul 30 '18 at 23:28
2
$\begingroup$

Typically, you should be able to leave User Preferences > File > Image Editor blank - as Blender will attempt to find 'gimp' on the system path. The 'Image Editor' preference is there as a means of selecting an alternative Image Editor or specifying where to find it if it isn't already on the path.

Note also that the '.desktop' file is a means of your window manager opening an application - Blender should not be using that as it will invoke 'gimp' directly. However, if you open the '.desktop' file then it will tell you what command clicking the 'Gimp' desktop icon will invoke (ie, where Gimp is installed if it isn't on your path).

Firstly, ensure that 'gimp' is on the path. You can do this by opening a 'terminal' window (I'm not too familiar with Mint but it should be something like 'Terminal', 'XTerm', 'Term', 'Command Window' or something similar) to get a command prompt. Then enter 'type gimp'. This should come back with something like :

gimp is hashed (/usr/bin/gimp)

This tells you that Gimp is available in /usr/bin/gimp and is on the system path.

If this is the case then you should simply be able to leave the 'Image Editor' in the File preferences blank - Blender will find it.

If gimp cannot be found (the 'type' command didn't locate it) then you'll need to specify the full path to 'gimp' (not the '.desktop' file). Locate it on your system and set the 'Image Editor' to that full path - so if 'gimp' is located at /usr/local/myversionofgimp/gimp then set the Image Editor to the full path to your 'gimp' executable (ie, '/usr/local/myversionofgimp/gimp').

$\endgroup$
  • $\begingroup$ Unfortunately your suggestions didn't work! If I leave Blender blank, it can't find anything and gives me an error. I checked the path again with a File Finder program and I got the same result. There is nothing in the path you suggested, I read in several forums that it depends on the distro. I'll try to upload a screenshot so you can see for yourself. $\endgroup$ – Miracles Happen Jul 27 '18 at 11:38
  • $\begingroup$ Thanks for the additional info. It looks like rather than a traditional gimp installation it’s using ‘flatpak’. I don’t have experience of that but suspect the command that’s shown on your screenshot is the command you need to set inside Blender (‘flatpak run —branch...’ put thr whole command in the Image Editor command. Failing that, can gimp be installed in the traditional form rather than via flatpak (you might need someone who knows the intricacies of flatpak to tell you that). $\endgroup$ – Rich Sedman Jul 27 '18 at 11:49
  • $\begingroup$ Looking at the Flatpak documentation (docs.flatpak.org/en/latest/using-flatpak.html) you should alternatively be able to use the command “flatpak run org.gimp.GIMP” - try that as the Image Editor command. $\endgroup$ – Rich Sedman Jul 27 '18 at 11:55
  • $\begingroup$ Yes, Rich I forgot to mention that I installed Gimp via flatpak to get the latest version without having problems (it is not available in the software manager and installing by terminal can sometimes create conflicting dependencies). I tried adding "flatpak run org.gimp.GIMP" but still it doesn't work. Anyway, I'll read the link you gave me. In the meantime thank you. $\endgroup$ – Miracles Happen Jul 27 '18 at 12:05
  • 1
    $\begingroup$ The problem is confirmed to be with Gimp 2.10 flatpack so I uninstalled everything and reinstall Gimp 2.8 PPA. Now everything works perfectly. Problem solved! $\endgroup$ – Miracles Happen Jul 28 '18 at 3:36
0
$\begingroup$

The problem is related to Gimp 2.10 Flatpak which can be downloaded directly from Gimp.org

According to the Gimp user forums, there are known issues with Flatpaks as well as Snaps and AppImage because they are very recent and have a certain number of issues that need to be tackled before they become really easy to use.

Solution: Uninstall Flatpak and reinstall Gimp 2.8 via PPA

sudo add-apt-repository ppa:otto-kesselgulasch/gimp

sudo apt update

sudo apt install gimp

In Linux Mint, the path for Blender Edit External IMages is the following:

/usr/bin/gimp

as Rich Sedman pointed out!

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.