1
$\begingroup$

I know that this question has been asked, but unfortunally there was no answer- maybe through a second try someone else will read this and can help.

Im pretty new to blender, so sorry for my messed up blender file.

enter image description here low res render smoke domain nodes

as you can see, the smoke domain of my cycles quick smoke effect is being rendered as a semi-transparent-box. i turned off the shadows in the cycle settings of the domain and the smoke object, so this is not the problem.

-> .blend

really looking forward for some help, greets, luk

$\endgroup$
  • $\begingroup$ dear rich, i added the .blend and the nodes. $\endgroup$ – Luk Emmers Jul 25 '18 at 14:43
  • $\begingroup$ I just checked out your file and it rendered fine for me. So I dont know what the issue is, but I think you should change your sample settings. Under Light Paths your volume was set to 0 bring that up around 4-8, You only had 16 Samples you need much much more for what you're trying to do (500-1000). $\endgroup$ – icYou520 Jul 25 '18 at 15:32
  • $\begingroup$ Also not sure what blender version you're using but I would download the latest version and use the Principled volume shader. $\endgroup$ – icYou520 Jul 25 '18 at 15:35
  • $\begingroup$ strange that it rendered out fine for you. i tried now with 500 samples and light path set to 4- same problem. i am using 2.79b. thanks for the help, ill give the principled shader a look. $\endgroup$ – Luk Emmers Jul 25 '18 at 18:55
  • 1
    $\begingroup$ I've tried rendering it on 2.76b and I get the same result as you - ie, the adaptive smoke domain (which is the line part way down the image) shows as a darker box. I don't have GPU so this is on CPU only. $\endgroup$ – Rich Sedman Jul 25 '18 at 21:54
1
$\begingroup$

The problem is actually due to your Light Path settings - in particular the number of Transparency Bounces which is causing the transparent surfaces of the domain to become visible.

Here's a render of your scene with your specific settings with the only change to the materials (of which I don't have the image textures so rendered with substitute solid colors) :

original

The Light Paths on your example .blend are set with very low numbers of bounces - too low for Blender to effectively render the image.

bad light path settings

By simply amending the settings by choosing the preset for 'Limited Global Illumination' in the Light Paths render properties I produced the following :

amended

good light path settings

The light path bounces can have significant impact on the final render - especially when set to very low values. The default values provide reasonable render results in most situations and care should be taken when decreasing them below the default values.

| improve this answer | |
$\endgroup$
1
$\begingroup$

Sorry this is not an answer.

I will delete, just so I can post a pic.

I just opened your file, disconnected all the image textures (because they were not packed)

Then I just hit Render with all your settings and it doesnt have that same error that yours does.

This is what I got.

enter image description here

Maybe someone else can try your file and see if they can replicate it. It seems like a hardware glitch. Change to a GPU (if you can) see if that changes anything.

| improve this answer | |
$\endgroup$
  • $\begingroup$ i now tried it with GPU- didnt work. Disconnected all textures- didnt work. i rendered the file i uploaded here on another computer- same problems! i dont get it... would be really interested if other users could render it without the transparent box? $\endgroup$ – Luk Emmers Jul 25 '18 at 21:06
  • $\begingroup$ Ok I think I have another idea, erase all of your smoke sim. The domain and the flow object. Then create your smoke plane again and make sure you use Quick Smoke (just hit space bar and type quick). I think This will fix it. I tried setting up a smoke scene manually (not using quick smoke) and I am getting some weird behavior now. $\endgroup$ – icYou520 Jul 25 '18 at 21:21
  • $\begingroup$ ok! it didnt worked on the file im working on, but creating a new file was working. i dont know what but something is messed up with the first file. thanks a lot! $\endgroup$ – Luk Emmers Jul 25 '18 at 22:59
0
$\begingroup$

Stack Exchange does not allow me to comment yet, so I try it here :-)

I see in your first image there is boundary of some object (orange color) going through the scene from door to window. This object is not part of file you sent (opened in v2.79). So, could it be obstacle in the way with some semitransparent on it?

| improve this answer | |
$\endgroup$
  • $\begingroup$ hi! thanks for your help. the orange-bound object is the smoke-domain of the quick-smoke-effect. dont know what you mean with an obstacle in the way? $\endgroup$ – Luk Emmers Jul 25 '18 at 18:57
  • $\begingroup$ just that I haven't seen that bounds of the domain (going horizontally through middle of the image) in the blend file from you. but I guess Rich Sedman got the solution ;-) $\endgroup$ – koubin Jul 26 '18 at 9:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.