0
$\begingroup$

Hey anyone that reads this, hopefully you can help me. I am a amateur blender user as I've only been on it for a week now.

I recently followed a tutorial on youtube to learn how to put clothes on a character mesh rigged for animation, but I ran into an issue when I wanted to manually weight paint the clothes mesh.

I'm going to run you through everything I did, just incase I've done something wrong.

I started by selecting the clothes mesh and adding a 'Data Transfer' modifier. on the modifier settings I located the main body mesh (The Girls Body) in 'Source Object:'. I then hit the check button on 'Vertex Data', and then turned the vertex Groups(s) button on. then I clicked the 'Generate Data Layers' Button.

Now firstly I Selected the clothes mesh, held shift and then selected the armature. Then I pressed on the keyboard (Ctrl P) to apply 'armature deform with empty groups' enter image description here

I then Selected the body mesh and then the clothes mesh and went into 'weight paint' mode. Now in the weight tools (on the left of the image) I applied 'transfer weights' (this opened the 'transfer mesh data settings). In these settings under 'source layers selection' I chose 'BY NAME'. enter image description here

Now when I put the armature in 'pose mode' and re-select the clothe mesh to go back into 'weight paint' mode. when I select a bone I can see That the weight paint data Has been transfered from the main body mesh. But when I try to use the weight paint brush nothing happens.I'v tried all brush types (add, draw,subtract, mix etc.) Ive tried using 'face selection masking for painting. this didn't work. I've also tried enabling auto normalize, this didn't help either. and no matter what bone I select the issue remains.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.