1
$\begingroup$

I was working on a scene with 2 groups of particles that were supposed to collide with an object.

I set the physics on the "collision object" to collision, in the preview the particles did collide, also in the render preview, but strangely in the final render the particles just went through the object.

I then started to watch tutorials to see if I did something wrong, nothing. As I'm kind of new in blender, I don't really understand the functions of some features, so I tried to bake everything and started messing with the cache in the particles settings.

Finally checked if the problem was in the particles settings or in the collision object, so I put another plain emitting particles into the same scene, still colliding with the object but with different settings.

Again in the preview everything was ok, also in render preview, but in the final render (both animated and only picture), neither the new plain nor the particles emitted appeared.

My conclusion is that the problem, has nothing to do with the particles or the collision object. I don't know if it's possible, but I think the final render is working with a previous version of the project.

I already checked the camera option in Cycles settings and the camera icon, that's not the problem.

$\endgroup$
  • $\begingroup$ If you are indeed experiencing a bug it will be easier to diagnose and fix if you provide the blend file you are working with. You can upload it here. $\endgroup$ – TechTornado Jul 19 '18 at 19:40
1
$\begingroup$

Instead of using "collision" for the collider in the physics tab, use "rigid body" and uncheck "dynamic" (in the photo "dynamic" is checked)

The picture is on: https://i.stack.imgur.com/XHQ2l.png

and make sure it gets rendered.

The picture is on: https://i.stack.imgur.com/3VNc6.png

In the particle tab of the emitter set Collision Group on RigidBodyWorld (it should appear if the collider is set as Rigid Body).

The picture is on: https://i.stack.imgur.com/EKu6b.png

It should work.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.