0
$\begingroup$

Am I doing something wrong or not aware of something here? I added two loop cuts on each side of a cube and tried to scale the middle faces on two axis (pressed S, then Shift+Z). But for some reason when scaled the top face on the corner is going beyond the vertex where it should have splitted it, while the bottom one is scaling like it should. That's happening on every corner face but some are flipped so that the bottom one is extending while the top one is fine.

I don't really understand what's going on since everything is connected (no double vertices) and everything is in quads.

Thanks in advance for the help on this silly problem.

P.S.
I know that there's a better way to go about this kind of shape since the topology isn't exactly pretty this way. I could've extruded individual faces of a simple cube and scaled up the inner corner edges more outside. I was just curious why in other applications, e.g. Maya it works fine while in Blender it breaks.

$\endgroup$
  • 2
    $\begingroup$ You are creating non-convex quads this way, so even if it is done as expected in the bottom (maybe a limitation of mesh preview) just avoid this type of geometry. Either triangulate or remodel. $\endgroup$ – Mr Zak Jul 13 '18 at 20:36
  • $\begingroup$ I am aware I'm creating non-convex polys this way but they're still quads and it should work. Tested in Maya and worked like expected so I'm surprised why Blender doesn't want to work. $\endgroup$ – user58963 Jul 13 '18 at 20:47
  • $\begingroup$ Mr Zak is right. They should but they don't so take steps to mitigate it rework your topology . Maya uses it's own different geometry engine, Blender's is more limited, the fact that it works there is irrelevant $\endgroup$ – Duarte Farrajota Ramos Jul 13 '18 at 23:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy