an object in my scene looks fine in all other views but shows up weirdly transparent/ invisible in the render? I've tried everything I could find online about invisible rendered objects but none of them worked. I'm a bit of beginner so this could be something obvious

Below is object next to a cube for comparison. it renders fine while the object seems to sort of be there and obstructs the cube but is the color of the background. This only happens in cycles render.

render viewport

solid viewport

solid viewport: Right now I can only theorize it might have something to do with grouping/ duplication, as I used a modifier to make the object symmetrical during modeling. Or it could be a material setting I haven't learned yet?

Link to the blender file (sorry about that!): https://www.dropbox.com/s/tzf2v0i57iu8tku/fruit%20basket%201.blend?dl=0

  • $\begingroup$ Can I have access to the blender file? $\endgroup$ Jul 13, 2018 at 3:30
  • $\begingroup$ It's easier for someone to help you if you upload the blend file here. In the absence of the blend file, it does seem like you have multiple blank materials assigned to the object so perhaps you have one of the bogus materials assigned to the object rather than Material.003? $\endgroup$ Jul 13, 2018 at 4:24
  • $\begingroup$ I've added a link to the file! $\endgroup$
    – user58930
    Jul 14, 2018 at 22:15

1 Answer 1


You have enabled Shadow Catcher the object.

Select it, go to the object properties in the Properties area, uncheck Shadow Catcher.

shadow catcher property

Shadow Catcher objects will appear as a transparent mask except for the shadows.

[The shadow catcher enables] the object to only receive shadow rays. It is to be noted that shadow catcher objects will interact with other CG objects via indirect light interaction. This feature makes it really easy to combine CGI elements into a real-world footage.

Manual Page


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .