2
$\begingroup$

I'm trying to apply soft body sim to a Manuel Bastioni lab human and all I can get as a result is a collapse of the body like cloth or explosion of everything.

How can I simulate the output human as it is a balloon filled with gel/water?

$\endgroup$
  • $\begingroup$ please share a screen shot of your current soft body settings. $\endgroup$ – rob Jul 12 '18 at 8:56
2
$\begingroup$

It's difficult to get convincing 'outward pressure' in a soft body but one trick is to simply use the 'bending' spring force to make the mesh attempt to retain its shape. In addition, try reducing the Mass of the soft body and significantly reduce the Gravity weight so as to make it 'float'.

Remove any modifiers that are no longer required (such as the default armature modifiers). Also, the default Manuel Bastioni Lab mesh includes a lot of unnecessary detail around the face and hands that will significantly slow down the simulation - and close-proximity vertices (especially around the fingers) can result in very strong repulsion forces if you enable 'self collision' - so best to either not use self collision or use 'Remove Doubles' on the mesh in Edit mode to cut down the detail a bit (this will potentially join adjacent fingers so use with care - possibly separate the fingers a bit first).

This can produce the following result :

animated

The soft body settings for this were as follows :

soft body settings

Note that the only changes from the defaults are to reduce the mass to 0.5, disable the Goal, increase edge Pull to 0.9, increase Bending to 5.0, reduce Gravity to 0.05.

Increase the Bending spring force even further for a more rigid (effectively more inflated) effect.

$\endgroup$
  • $\begingroup$ Thanks for your detailed answer, I still get this Explosion like issue also with your sim settings and removing armature modifiers. after this "explosion" I can only see eyes ant tooth. Can you please provide more details regarding the model preparations? $\endgroup$ – yossico Jul 12 '18 at 19:52
  • $\begingroup$ @yossico The only changes I made to the mesh were to Select All in Edit mode, select Remove Doubles and increase the threshhold of the Remove doubles until a point where it didn’t quite cause too much distortion (so I’d removed as much of the fine geometry I could get away with). The only other thing was that I removed the separated elements - tongue, eyeballs, etc.- but those shouldn’t impact the rest of the mesh providing you don’t enable Self Collision. If you can share your blend file (upload it to blend-exchange and then edit your question to include the link to it) then I’ll take a look. $\endgroup$ – Rich Sedman Jul 12 '18 at 20:02
  • $\begingroup$ I Didn't deleted all the eyelids - its working now, thanks!!! $\endgroup$ – yossico Jul 13 '18 at 5:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.