0
$\begingroup$

I have installed Blender in Windows 10 pro and everything works fine until I try to load an image texture in Cycles.

I get the message can not read image texture denied permission

I have two hard drives, one SSD and one normal. I install Blender on the SSD and the textures in one folder on the other disk.

I have tried to run Blender as administrator, to download it in .zip on the normal disk and open it without installing it, to load the texture saving it in "my images" but the failure continues.

I have loaded a .blend file with the packed textures and renders perfect. If I unpack the textures and load them, Blender reads them but in some objects it does not show them (the purple color of warning comes out).

The problem happens when I try to load from any other location. Textures do not have restriction permissions.

$\endgroup$
  • $\begingroup$ Related blender.stackexchange.com/questions/84602/… also see other instances blender.stackexchange.com/search?q=denied+permission $\endgroup$ – Duarte Farrajota Ramos Jul 11 '18 at 18:54
  • $\begingroup$ can you create a new image put in various locations and just test that it can be read into Blender in the default scene? Then can you use those working images on the materials in your problematic .blend. Break the problem down to the smallest components and work up. $\endgroup$ – rob Jul 12 '18 at 9:17
  • $\begingroup$ I have already tried to do and doesn´t work.I have see now that i have the same problem when i try to put a background image. Cannot read 'D:\TEXTURASEscritorio\DIELECTRICOS\DesertSand\TexturesCom_DesertSand1_1024_albedo.tif': Permission denied $\endgroup$ – Manuel Jul 12 '18 at 19:06
1
$\begingroup$

Finally I found how to solve the problem.

I have downloaded blender in the C drive, in which I have windows instaled. I have downloaded in the folder Users / user (me). I installed it and click right mouse button, repair option. Then I restarted the computer and solved problem.

$\endgroup$
1
$\begingroup$

I was having the same issue and found out that my anti-virus program (IOBit Advanced SystemCare Ultimate 11) was denying Blender access to my photos. I had to "ALLOW' access and check the remember box.

$\endgroup$
  • $\begingroup$ Experimental versions of Blender are especially prone to blocking by ransomware protection services and antivirus programs. $\endgroup$ – VRM Oct 29 '18 at 15:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.