0
$\begingroup$

I made a little program for animating coordinates. It worked fine with a cube.

enter image description here

Then I imported a .dae model that I had exported from SketchUp. It imported fine, but when I tried to use the program on it, it became huge, and I do not know how to resize it (I tried changing the scale variables, but they just revert back).

Before (before)

After (after)

Thanks in advance for any suggestions.

Update:

Here is the file: http://pasteall.org/blend/index.php?id=49915 The robot was the size of the cube before linking it to my program.

$\endgroup$
3
  • $\begingroup$ Can you upload a .blend file for us to examine? $\endgroup$ Jul 10, 2018 at 17:19
  • $\begingroup$ "won't let me resize it", what won't let you resize it? What did you try? $\endgroup$
    – Omar Emara
    Jul 10, 2018 at 17:24
  • 1
    $\begingroup$ What did you find online and didn't work? $\endgroup$
    – Omar Emara
    Jul 11, 2018 at 14:54

1 Answer 1

1
$\begingroup$

I tried changing the scale variables, but they just revert back.

I am assuming by that you mean you are changing the scale of the parent object SketchUp through Blender---And not Animation Nodes. It simply reverts because Animation Nodes is overwriting the the scale of the object as defined by the Object Matrix Output Node. So, instead of changing the scale manually, define it in your node tree through the Compose Matrix Node.

Scale Object

Another method---Which I do not recommend due to its unpredictable consequences---is to set the scale of matrix to the scale of the object. By doing so, any manual change in the scale of the object is met with change in the scale of the matrix and is translated into a normal scaling behavior.

Manual Scalling

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .