2
$\begingroup$

some keyframes are undeletable in dope sheet. enter image description here

enter image description here

But, they can be deleted one by one in 3D view in object mode..... This is annoying... How to delete all the keyframes at once? enter image description here enter image description here The file is attached below:

untitle.blend

$\endgroup$
  • $\begingroup$ Can you delete them in the graph editor instead? $\endgroup$ – Nathan Jul 8 '18 at 20:25
  • $\begingroup$ The undeletable part are not shown in graph editor... I found this happen only when I added IK feet to the avatar....@Nathan $\endgroup$ – 萌香ちゃん Jul 9 '18 at 0:23
  • $\begingroup$ so what are those keyframes for, feet controllers? Please give more informations, or share your file $\endgroup$ – moonboots Jul 9 '18 at 7:42
  • $\begingroup$ Probably, I am not sure. I don't know how to remove it at once. I only can remove it frame by frame in object mode in 3D view.... The file is attached... @moonboots $\endgroup$ – 萌香ちゃん Jul 9 '18 at 21:09
1
$\begingroup$

As you see on my screenshot, some bones have been assigned to some invisible layers, so, even if you can see that there are some active keyframes on the top horizontal tracks of your Dopesheet, you can't see what bones, nor delete those keyframes.

So you can either:

  • Enable these layers to display those bones (in the 3D view) and their keyframes (in the Dopesheet)

  • Click on the button Include Channels From Objects/Bones That Are Not Visible (phantom icon) on the horizontal menu on the bottom of your Dopesheet window to display these hidden keyframes in the Dopesheet

enter image description here

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.